Mostrando entradas con la etiqueta RFC2544. Mostrar todas las entradas
Mostrando entradas con la etiqueta RFC2544. Mostrar todas las entradas

miércoles, 4 de abril de 2018

¿ Cómo lanzar una RFC2544 con el NT1003 de Metrodata ?

En este post te explicamos de forma sencilla cómo lanzar una RFC2544 con dos equipos NT1003 o con un equipo NT1003 actuando como bucle o como generador de tráfico.


El NT1003 es un punto de demarcación que incorpora medidas de activación del servicio (SAM) según RFC2544 e ITU Y.1564 y medidas de monitorización del servicio según ITY Y.1731 y TWAMP Lite.

En el post de hoy nos centraremos únicamente en cómo usar el NT1003 para realizar un medida RFC2544 para un circuito Ethernet punto a punto.

Veremos tres escenarios:
  • medida usando un NT1003 en cada extremo

  • medida usando un NT1003 remoto en bucle

  • medida usando un NT1003 local como generador de tráfico

RFC2544 usando dos equipos NT1003


En este ejemplo conectaremos un equipo NT1003 en cada uno de los extremos del circuito Ethernet a medir. El extremo local (izquierda) actuará como generador de tráfico mientras que el extremo remoto (derecha) actuará como bucle de dicho tráfico.

Por defecto, el NT1003 viene configurado como un bucle de nivel 2 en el puerto WAN. Por defecto el puerto WAN es el puerto eléctrico 10/100/1000BaseTX rotulado como RJ45#2. Si nuestro circuito fuera de fibra, deberíamos insertar el módulo SFP adecuado y cambiar el switch 1 de posición para usar el puerto SFP como WAN. En el equipo no tendremos que configurar nada más.

El equipo local tendremos que configurarlo como Tester y RFC2544. Para ello necesitaremos un PC que configuraremos en el rango 169.254.0.0/16 y arrancaremos cualquier navegador web a la dirección por defecto del equipo 169.254.42.42.

El password por defecto es 'nt1003'. A continuación en el menú principal seleccionaremos la opción Testing y en Tester Mode pincharemos sobre Loopback y seleccionaremos la opción Tester y a continuación exit.

En la pantalla de Testing pincharemos en Test regime y seleccionaremos RFC2544.A continuación pincharemos en Save para guardar los cambios. De nuevo en la pantalla de Testing pincharemos en Test Parameters.

Si el circuito Ethernet tiene definida alguna VLAN para pasar el tráfico y poder realizar la prueba deberemos entrar el tag de esa VLAN en el campo C-VLAN. En cuanto al extremo remoto Peer Name, si los equipos Ethernet que conforman el circuito Ethernet son transparentes bastará dejar el valor 'magic mac' que corresponde a la dirección MAC genérica de Loopback 00.C0:81:FF:00:00. Si por el contrario existen nodos o equipos intermedios en la red que pudieran interpretar esta dirección MAC y buclarla internamente, en este caso deberíamos introducir la dirección MAC de bucle específica del equipo remoto. Esta dirección se obtiene a partir de la dirección MAC del equipo remoto y fijando el bit 23 a '1', es decir, haciendo una OR con 00:00:00:80:00:00. Por ejemplo, si la MAC del equipo remoto es 00:C0:81:00:18:58, la dirección de Loopback que deberíamos indicar en la medida sería 00:C0:81:80:18:58. La dirección MAC del equipo la podemos ver en la etiqueta del número de serie en la base del equipo o también en el menú Info de configuración del equipo.

A continuación podemos personalizar los diferentes parámetros de la medida RFC2455 incluyendo los tamaños de trama a probar, los test a realizar y los tiempos de cada uno de los tests.

Una vez configurada la prueba la lanzaremos pinchando en Start Test. Pinchando en Test Progress accederemos a una ventana donde podemos ver el progreso del test.

Una vez finalizado el test aparecerá al final de la página el texto testing complete.

Finalmente en la página de Testing si pinchamos en View Report se nos abrirá en una nueva pestaña con el resultado del test en formato texto. Basta guardar la página como fichero de texto para poder almacenar dicho resultado.

Recordemos fijar la hora y fecha del equipo NT1003 si queremos que esta información aparezca correctamente en nuestro informe.

RFC2544 usando un equipos NT1003 como bucle remoto


En este ejemplo conectaremos un equipo NT1003 en el extremo remoto como bucle de tráfico y un equipo de medida en el extremo local como generador del tráfico. De esta forma nos evitamos un segundo equipo de medida para el extremo remoto y su configuración.



En el equipo NT1003 no deberemos configurar nada.

En el equipo de medida tendremos que seguir las instrucciones del ejemplo anterior a la hora de configurar la dirección MAC del equipo remoto. Es decir, si no hay equipos que puedan buclar el tráfico podremos usar la dirección MAC 00.C0:81:FF:00:00. En caso contrario deberemos usar la dirección MAC de Loopback específica del equipo remoto según el algoritmo descrito en el ejemplo anterior.

RFC2544 usando un equipo NT1003 como generador de tráfico


En este último ejemplo usaremos un equipo de medida configurado en bucle y un equipo NT1003 en el extremo local como generador del tráfico. Al igual que en el ejemplo anterior, evitamos un segundo equipo de medida para el extremo local y su configuración.



La configuración del equipo NT1003 es idéntica al primer ejemplo teniendo en cuenta que deberemos confirmar el funcionamiento exacto del equipo de medida remoto en modo bucle. Si no podemos asegurar que hará bucle de todo el tráfico o de la dirección MAC genérica de Loopback 00.C0:81:FF:00:00 deberemos anotarnos la dirección MAC del equipo de medida e introducirla en el campo Peer Name en los parámetros de la medida RFC2544.

lunes, 19 de marzo de 2018

Webinar Gratuito - Quieres saber cómo medir los SLA en tus enlaces Ethernet o cómo lanzar una RFC2544 sin un costoso equipo de medida?

• Como puedo lanzar una medida RFC2544 para activación del servicio sin equipos de test Ethernet costosos y difíciles de manejar?
• Ha provisionado mi enlace mi provedor de servicios de acuerdo a mis requerimientos?
• Con qué frecuencia estamos experimentando...

• Como puedo lanzar una medida RFC2544 para activación del servicio sin equipos de test Ethernet costosos y difíciles de manejar?

• Ha provisionado mi enlace mi provedor de servicios de acuerdo a mis requerimientos?

• Con qué frecuencia estamos experimentando problemas en la red o qué porcentaje del tiempo la red está simplemente caída?

• Los parámetros de latencia y variación (jitter) de la misma están dentro de los permitidos para mi servicio de telefonía sobre IP?

• Si implantamos un nuevo servicio de video conferencia entre nuestras sedes, como impactará esto en el resto de servicios que corren actualmente sobre la misma red?

• Varía el rendimiento de nuestra red a lo largo del día o del mes o por el contrario permanece inalterado?

Si quieres respuestas a estas preguntas puedes apuntarte a nuestro webinar gratuito donde te explicaremos:
• las diferencias entre las medidas de puesta en servicio RFC2544 e Y.1564
• el funcionamiento de los equipos NetTESTER para realizar medidas 'en servicio' según Y.1731 y TWAMP
También te explicaremos como lanzar una medida RFC2544 desde el equipo NetTESTER contra cualquier otro medidor en bucle y guardar la medida en formato de texto.
Fecha y hora: Miércoles, 21 de Marzo a las 16:00
Duración aprox: 30 min.


NT1003 - NetTESTER

miércoles, 7 de marzo de 2018

Medidas de activación de circuitos Ethernet - RFC2544 vs Y.1564

Las normas RFC244 e IUT Y.1564 definen medidas para la validación de un enlace Ethernet frente a unos parámetros de calidad. En este post veremos cómo funcionan y qué ventajas aporta Y.1564 sobre RFC2544


En el post de hoy veremos los dos tipos de medida existentes para la activación de un circuito Ethernet: RFC2544 e ITU Y.1564

RFC2544


Las medidas RFC2544 fueron pensadas originalmente para medir la capacidad real de un dispositivo Ethernet en términos de caudal (Throughput), retardo (latencia) y pérdida de paquetes (Frame Loss Ratio o FLR). Cada una de estas medidas se realizan con diferentes tamaño de paquetes (típicamente desde 64 bytes a 1518 bytes) para ver su influencia en las mismas.

Normalmente usaremos un equipo de medida con dos puertos o interfaces donde uno de ellos inyectará el tráfico y el otro o bien lo recibirá o bien actuará como un bucle inteligente retornando el tráfico de medida de nuevo al puerto inyector para su comprobación.

Throughput


Para cada tamaño de paquete se lanza una primera medida al 100% del caudal o capacidad del interfaz físico entre el equipo de medida y el equipo a medir (por ejemplo: 10G, 1G o 100M). El equipo de medida cuenta las tramas en transmisión y en recepción. Si se pierde alguna trama se repite la medida reduciendo el caudal del tráfico en un % determinado y así sucesivamente hasta que la medida no pierda tramas.

Latencia


En esta medida marcamos una trama de las inyectadas con un marca de tiempo. Cuando recibimos esta misma trama restamos el tiempo actual del tiempo de la marca (momento de la inyección) teniendo así el retardo de la trama. En caso de que hagamos un bucle en uno de los puertos del equipo de medida estaremos realmente midiendo el retardo de ida y vuelta (round trip delay o RTD). Si asumimos simetría en los retardos (no cual no es cierto en muchos casos) podemos concluir que la latencia es la mitad del RTD. En medidas entre puntos remotos, sólo podremos mediar la latencia si el equipo inyector y el receptor están perfectamente sincronizados (GPS, PPTP o similar). En caso contrario siempre haremos un bucle en el extremo remoto y mediremos el RTD.

Frame Loss Ratio


De forma similar a la medida de Throughput, la medida de pérdida de paquetes (FLR ) realiza una primera prueba a la máxima velocidad del interfaz y luego va bajando un % definido hasta alcanzar una medida sin pérdida de paquetes (FLR=0).

Inconvenientes de RFC2544


Los principales inconvenientes de este tipo de medidas son los siguientes:
  • Pensada para entorno de laboratorio pero no en campo real

  • Pensada para una conexión punto a punto (mide la capacidad máxima de un link), pero no para un servicio ‘end-to-end’ con múltiples enlaces ni velocidades inferiores al caudal máximo del enlace físico

  • No permite distinguir el tráfico por QoS (ToS, VLAN, DSCP, …). Todo se mide igual.

  • No permite obtener unos resultados contrastables con los parámetros definidos en un SLA (Service Level Agreement) puesto que no se miden exactamente los mismos parámetros (KPI)

Y.1564


Para solucionar todos estos inconvenientes, la ITU estandarizó la normativa Y.1654 para realizar medidas de activación de enlaces/servicios Ethernet. Por tanto, esta norma:
  • Permite medir el SLA de múltiples servicios sobre un mismo enlace físico

  • Permite reducir el tiempo de medida y medir variaciones de latencia (FDV Frame Delay Variation) que a veces es un parámetro de mayor relevancia que la propia latencia de la red

Servicios y SLA (CIR + EIR)


Las medidas de caudal y  FLR son sustituidas en este caso por un perfil de ancho de banda que debe cumplir con un SLA (Service Level Agreement) de acuerdo con el establecido por el proveedor del servicio de transporte Ethernet.

Este perfil de servicio nos indica cuál es la cantidad máxima de tráfico que el cliente puede cursar así como la prioridad de los diferentes flujos de datos y se basa en tres tipos de tráfico:
  • CIR ( COMMITED INFORMATION RATE), tráfico garantizado o verde, velocidad máxima (KBPS, MBPS, GBPS) sin sufrir pérdidas o descartes.

  • EIR ( EXCESS INFORMATION RATE), tráfico amarillo es el exceso por encima del CIR y que podría presentar pérdidas en caso de congestión de la red.

  • TRÁFICO DESCARTADO o rojo, tráfico por encima del EIR que no puede ser transmitido sin descartar otros tráficos
También podemos encontrar los siguientes parámetros:
  • CBS (COMMITTED BURST SIZE) TAMAÑO DE RÁFAGA COMPROMETIDO, valor en Kbytes o Mbytesequivalente al número máximo de tramas consecutivas cuyo envío está garantizado a la velocidad máxima de línea. Por ejemplo: un servicio contratado con CIR=10 Mbps, CBS=20 KB en una línea de 100Mbps, se garantizará el envió de ráfagas de 20 KB a 100Mbps

  • EBS (EXCESS BURST SIZE) TAMAÑO DE RÁFAGA EN EXCESO, valor en Kbytes, Mbytes equivalente al número máximo de tramas consecutivas por encima del CBS que serán enviadas a la red en Best Effort, pero podría haber pérdida de tramas en caso de congestión de la red. Por ejemplo: un servicio contratado con CIR=10 Mbps, CBS=20 KB, EBS=25 KB en una línea de 100Mbps, se garantizará el envío de ráfagas de 20KB a 100Mbps y los siguientes 25KB se enviarán según Best Effort sin garantía de entrega.

Métricas


Las métricas o medidas que define Y.1564 sólo aplicar al tráfico CIR y corresponden con los parámetros de calidad del servicio que defina el proveedor del mismo.
  • FTD (FRAME TRANSFER DELAY o LATENCIA)  retardo de transferencia de trama. Es el tiempo máximo (en ms) que las tramas pueden tardar desde el origen al destino. Si los extremos no tienen un mecanismo para sincronizar sus relojes entonces se mide el RTD (ROUND TRIP DELAY) o retardo de ida y vuelta, donde la trama es devuelta por un bucle en el extremo remoto y la medición se realiza únicamente en el extremo local.

  • FDV ( FRAME DELAY VARIATION) variación de retardo de trama o JITTER máximo (ms)  permitido. Importante para transmisión de voz y video.

  • FLR (FRAME LOSS RATIO) porcentaje máximo de tramas perdidas (% o 10E-X) del total transmitidas.

  • AVAIL ( AVAILABILITY) disponibilidad mínima (%) del servicio que aún cumple con el SLA. El servicio se considera no disponible si más del 50% de las tramas son erróneas o se han perdido en un intervalo igual o superior a 1 seg. (estos criterios pueden personalizarse por el operador en función del tipo de servicio proporcionado)

Conclusiones


Como consecuencia de la anterior podemos extraer las siguientes conclusiones:
  • RFC2544 sirve para medir un enlace punto a punto entre dos equipos, no para medir un servicio ‘end-to-end’ que involucra diferentes redes y tecnologías de transporte

  • Y.1564 resuelve las limitaciones anteriores y ofrecer KPIs asimilables a los SLA de los servicios

  • Ambas mediciones son ‘intrusivas’ y por tanto se deberán usar únicamente para la puesta en servicio y obtención del ‘birdth certificate’

lunes, 29 de enero de 2018

Un completo medidor Gigabit Ethernet por menos de 500,00 EUR

Hoy te queremos presentar el NT1003 que es un equipo de demarcación Ethernet que puede usarse como un medidor sobre cobre o fibra a velocidades Gigabit Ethernet y también como equipo para monitorizar la calidad de tus enlaces Ethernet una vez en servicio.

NT1003 Network Tester
2 ports 10/100/1000BaseT
1 port 100BaseFX/1000BaseX (SFP)
Alimentación AC / DC

Medidas de activación del servicio (SAM o Service Activation Measurements)


El NT1003 permite realizar medidas según las normas RFC2544 o Y.1564 sobre redes de nivel 2 o incluso redes ruteadas de nivel 3. Con él podrás realizar las mediciones necesarias para la activación de tu servicio Ethernet.

Para ello colocaremos un equipo en un extremo como generador de tráfico y otro como reflector en el extremo remoto del enlace a medir, devolviendo el tráfico recibido del generador y pudiendo medir así paquetes perdidos o retardos de la red de transporte.

En el extremo remoto no tendremos que hacer absolutamente nada ya que el equipo viene configurador de fábrica como reflector. En el extremo generador, la configuración y realización de las pruebas puede llevarse a cabo de forma sencilla a través de comandos por consola o Telnet o incluso de forma gráfica e intuitiva a través del servidor web integrado en el equipo. Tras el primer servicio podemos guardar en el equipo todas las configuraciones de las medidas a realizar para recuperarlas, de forma rápida, en las siguientes puestas en servicio.

Asimismo, los resultados de las medidas de activación de servicio pueden presentarse por pantalla o exportarse a un fichero de texto para que puedas adjuntarlas a la documentación de alta del servicio.




Medidas de calidad de la red


El NT1003 también puede usarse como sonda dentro de tu red Ethernet a fin de poder monitorizar la calidad de la misma.

En esta configuración puedes colocar un equipo NT1003 en cada extremo del enlace a monitorizar o bien un equipo NT1005 como generador y hasta 16 equipos NT1003 como reflectores.

Podrás realizar medidas continuas dentro de tu red de acuerdo con las normas Y.1731 (nivel 2) o TWAMP-Lite (nivel 3). Estas medidas incluyen pérdidas de paquetes, retardo y latencia (variación del retardo). Además, podrás configurar un nivel de servicio (SLA o Service Level Agreement) y si las medidas exceden este SLA recibirás una alarma en forma de TRAP SNMP.



Puedes ampliar esta información en nuestra web